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Abstract

BibleTime is a completely free Bible study program. The program's user interface is built with the Qt framework,
which makes it run on several operating systems including Linux, Windows, FreeBSD and Mac OS X. The software
uses the SWORD programming library to work with over 900 free Bible texts, commentaries, dictionaries and books
in over 50 languages provided by the Crosswire Bible Society and several other repositories.

The BibleTime Handbook is distributed with the BibleTime study program.
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Chapter 1. Úvod
O BibleTime

BibleTime is a Bible study tool with support for different types of texts and languages. Even large amounts
of works modules are easy to install and manage. It is built on the SWORD [http://www.crosswire.org/
sword/] library, which provides the back-end functionality for BibleTime, such as viewing Bible text,
searching etc. SWORD is the flagship product of the Crosswire Bible Society [http://www.crosswire.org].

BibleTime je navržen k použití s díly v jednom z formát# podporovaných projektem SWORD.
Kompletní informace o podporovaných formátech dokument# naleznete ve vývojá#ské sekci [http://
www.crosswire.org/sword/develop/index.jsp] na stránkách projektu SWORD, Crosswire Bible Society.

Dostupná díla
Over 280 documents in 50 languages are available from the Crosswire Bible Society [http://
www.crosswire.org]. These include:

Bible Úplný text Bible, s volitelnými v#cmi jako Strongova #ísla, nadpisy, nebo
poznámky v textu. Bible jsou dostupné v mnoha jazycích, nejen v moderních
verzích, ale také ve starov#kých jako Codex Leningradensis (Kodex
Leningradský; "WLC", Hebrejsky), nebo Septuaginta ("LXX", #ecky). Toto
je nejmodern#jší sekce knihovny projektu SWORD.

Knihy Dostupné knihy jsou "Imitation of Christ", "Enuma Elish", a"Josephus: The
Complete Works"

Komentá#e Dostupné komentá#e zahrnují klasiku jako "Notes on the Bible" Johna
Wesleyho, komentá#e Matthewa Henryho a Luther#v "Komentá# ke
galatským." Pomocí Osobníhokomentá#e m#žete nahrát osobní sešit
poznámek do biblických sekcí.

Denní zamyšlení Mnoho lidí oce#uje tyto denní porce Božího slova. Mezi dostupná díla pat#í
"Denní sv#tlo na cestu" a "Losungen".

Lexikony/slovníky Lexicons available include: Robinson's Morphological Analysis Codes, and
the International Standard Bible Encyclopaedia. Dictionaries available include
Strong's Hebrew Bible Dictionary, Strong's Greek Bible Dictionary, Webster's
Revised Unabridged Dictionary of the English Language 1913, Nave's Topical
Bible.

There are several other repositories that BibleTime will load and use.

Motivace
P#ejeme si sloužit Bohu a p#isp#t svým dílem ostatním v r#stu ve vztahu s Ním. Chceme, aby byl tento
výkonný a kvalitní program stále jednoduchý a intuitivní. P#ejeme si chválit Boha, nebo# on je zdroj
všeho dobrého.

Každý dobrý dar a každé dokonalé obdarování je sh#ry, sestupuje od Otce nebeských
sv#tel. U n#ho není prom#ny ani st#ídání sv#tla a stínu.

—Jakub#v 1:17
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Úvod

B#h vám žehnej p#i používání tohoto programu.
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Chapter 2. Spušt#ní BibleTime
Jak spustit BibleTime

Spušt#ní BibleTime
BibleTime is an executable file that is integrated with the desktop. You can launch BibleTime from the
Start Menu with this icon:

BibleTime can also be launched from a terminal command prompt. To launch BibleTime, open a terminal
window and type:

bibletime

Nastavení spušt#ní
From a terminal you can use BibleTime to open a random verse in the default bible:

bibletime --open-default-bible "<random>"

To open at a given passage like John 3:16, use:

bibletime --open-default-bible "Jan 3:16"

You can also use booknames in your current bookname language.

Starting BibleTime for the first time
If you are starting BibleTime for the first time, you will want to configure the following options, available
under the Settings menu bar.

Bookshelf Manager Modifies your Bookshelf. This dialog lets you modify your
Bookshelf, add or delete works from your system. It will only
be shown if no default Bookshelf can be found. Please see The
Bookshelf Manager section for further details. If you start off with
an empty Bookshelf, it will be helpful to install at least one Bible,
Commentary, Lexicon and one Book to get to know BibleTime's
basic features quickly. You will be presented with a list of works
that are available from the Crosswire Bible Society and other
repositories;

Configure BibleTime dialog P#izp#sobí BibleTime.Tento dialog vám dovolí p#izp#sobit
BibleTime vašim pot#ebám. Prosím podívejte se na detailní popis
tohoto dialogu.
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Chapter 3. Operace programu

Náhled programu
This is what a typical BibleTime session looks like:

You can easily see the different parts of the application. The top left window is used to open installed
works in the Bookshelf tab, and with the Bookmarks tab you can manage your bookmarks. The little "Mag"
window below the Bookshelf is used to display extra information that is embedded in documents. When
you move your mouse over a footnote marker, for example, then the Mag will display the actual content
of the footnote. The toolbar gives you quick access to important functions, and the Desk on the right side
is where you do your real work.

Nyní se podívejme na vzhled r#zných #ástí aplikace individuáln#.

#ásti okna aplikace BibleTime

Knihovna

Knihovna obsahuje všechna nainstalovaná díla, set#íd#ná podle kategorií a jazyk#. Obsahuje také kategorii
"Záložky" To je místo, kam m#žete uložit své záložky a poté k nim p#istupovat.

Opening works

To open a work from the bookshelf for reading, simply double-click with the left mouse button on
the desired category (Bibles, Commentaries, Lexicons, Books, Devotionals or Glossaries) to display its
contents. Then just double-click on one of the works to open it for reading. A read window will appear
in the Desk area.

Pokud #tete n#jaké dílo a chcete otev#ít stejnou pasáž v jiném díle, m#žete použít zkratku. jednoduše
klikn#te levým tla#ítkem myši na odkaz verše nebo kapitoly (kurzor se zm#ní v ruku) a p#etáhn#te ho do
knihovny. Upus#te ho na dílo, které chcete otev#ít ,a to bude otev#eno na požadovaném míst#. M#žete
také p#etáhnout odkaz verše na existující okno, které se p#esune na požadované umíst#ní.

Další informace o dílech

Pokud kliknete pravým tla#ítkem myši na symbol díla, objeví se nabídka s dalšími možnostmi, které jsou
relevantní pro toto dílo. "O tomto díle"otev#e okno s mnoha zajímavými informacemi o zvoleném díle.
"Odemknout toto dílo" otev#e malý dialog pro zašifrované dokumenty, kde m#žete vložit p#ístupový
kód k otev#ení díla. Pro další informace o zam#ených dílech se podívejte na  Zam#ené moduly [http://
www.crosswire.org/sword/modules/aboutlocked.jsp] na webu Crosswire Bible Society.

Vyhledávání v dílech

Vyhledávat v díle m#žete kliknutím pravým tla#ítkem myši na jeho symbol a vybráním položky"Hledat
v díle(ch)". Stiskem klávesy Shift a kliknutím na další díla m#žete vybrat více než jedno. Poté následuje
stejný proces s otev#ením vyhledávacího dialogu. Budete vyhledávat ve všech t#chto dokumentech.
Kompletní popis obsluhy vyhledávacích funkcí naleznete v sekci Vyhledávání v dílech.
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Operace programu

Práce se záložkami

Tip

Chy# & pust dílo
Klikn#te pravým tla#ítkem myši na kategorii záložek v knihovn# a vyberte "Vytvo#it novou složku",
pokud chcete vytvo#it novou podsložku záložek. M#žete použít b#žnou funkci "drag & drop " k
p#etáhnutí odkazu verše z otev#ených oken, nebo výsledk# vyhledávání do adresá#e záložek, stejn# tak
pro p#esouvání záložek mezi složkami.

M#žete také importovat záložky od ostatních, nebo je exportovat a sdílet. K tomu otev#ete kontextové
menu adresá#e záložek jak bylo popsáno p#edtím a vyberte "Exportovat záložky". Toto otev#e dialog pro
uložení vaší kolekce záložek. Stejným zp#sobem m#žete záložky importovat.

Klikn#te pravým tla#ítkem myši na adresá#e a záložky, pokud chcete zm#nit jejich jméno nebo popis.

#asopis
Toto malé okno v levém spodním rohu okna BibleTime pasivní. Kdykoli je váš kurzor umíst#n nad
n#jakým textem s dalšími informacemi (nap#. Strongova #ísla), potom budou tyto informace zobrazeny
v okn# #asopisu, ne v textu samotném. Prost# to vyzkoušejte.

Plocha
Plocha je místo, kde probíhá skute#ná práce s BibleTime. Zde m#žete otvírat díla z knihovny, #íst je,
hledat v nich a rovnou ukládat vaše poznámky v modulu osobních komentá## (podívejte se dol#).

#tení d#l

Jak už jsme vid#li, m#žete jednoduše otevírat díla pro #tení kliknutím na jejich symbol v knihovn#. Okno
díla se otev#e na ploše. Každé okno díla má nástrojovou lištu. Zde najdete nástroje k navigaci propojené
s dílem, nap#íklad tla#ítka historie jako ve vašem webovém prohlíže#i.

Auto Scrolling

The currently active window can be auto scrolled up or down. Start scrolling by press Shift+Down. You
can increase the scrolling speed by pressing Shift+Down multiple times. To pause scrolling press Space.
To start scrolling again at the previous speed press Space again. To slow down scrolling or scroll the other
direction press Shift+Up one or more times. Pressing any other key or changing the active window will
stop the scrolling.

Umíst#ní aktivního okna

Samoz#ejm# m#žete mít otev#eno více d#l ve stejné dob#. Máte n#kolik možností jak umístit okna na
ploše. Prosím podívejte se na položku Okno v hlavním menu. Tam uvidíte, že umíst#ní oken m#žete
ovládat bu# osobn#, nebo zvolit automatické umíst#ní BibleTime. Toho docílíte volbou jednoho z
automatických mód# umíst#ní, které jsou p#ístupné p#es Okno → Mód rozvržení. Prost# to vyzkoušejte,
je to snadné a funguje to.

Úpravy vašich vlastních komentá##

Aby jste mohli ukládat vlastní komentá#e #ástí Bible, musíte nainstalovat dílo z knihovny Crosswire Bible
Society [http://www.crosswire.org], které se jmenuje "Personal commentary" ("Osobní komentá#").
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Operace programu

Open the personal commentary by clicking on its symbol in the Bookshelf with a left mouse button. You
can edit this commentary by just clicking on any verse. A dialog opens which allows you to add or edit
text for that verse.

Tip

Pokud je položka Upravit toto dílo deaktivována, prosím zkontrolujte zda máte oprávn#ní k
zápisu do soubor# osobních komentá##.

Tip

P#etáhn#te & upus#te díla zde. Pus#te odkaz verše a bude vložen jeho text.

Vyhledávání v dílech

Vyhledávání textu v aktivním okn#
Když chcete hledat slovo nebo frázi v otev#eném aktivním okn# (nap#. kapitolu bible, kterou #tete), je to
stejné jako v jiných programech. Tuto funkci m#žete vyvolat kliknutím pravým tla#ítkem myši a zvolením
Najít..., nebo použitím horké klávesy CtrlF. P#e#t#te si jak hledat v celých dílech.

P#ístup k dialogu vyhledávání
V díle m#žete hledat kliknutím pravým tla#ítkem myši na symbol v Knihovn# a vybráním Hledat ve
vybraných dílech. P#idržením Shift nebo Ctrl a kliknutím na jména dalších d#l m#žete vybrat více než
jedno dílo. Poté následuje stejný postup otev#ení dialogu hledání. Budete hledat ve všech t#chto dílech
najednou.

Vyhledávací dialog spustíte kliknutím na Hledat z hlavního menu a vybráním odpovídající položky.

T#etí možnost jak spustit vyhledávání je kliknutím na symbol hledání v aktuálním okn#.

Nastavení vyhledávání

Výb#r d#l

Naho#e v okn# nastavení vyhledávání najdete tla#ítko Vybrat (nebo Choose) (díla). Pokud chcete
vyhledávat ve více dílech, klikn#te na toto tla#ítko, poté vám bude nabídnuto menu s možností výb#ru
d#l ve kterých chcete vyhledávat.

Použití oblastí vyhledávání

M#žete použít rozsah hledání zvolením ur#itých #ástí Bible pomocí jedné z definovaných oblastí v
seznamu Rozsah hledání M#žete definovat vlastní vyhledávací rozsahy kliknutím na tla#ítko Nastavit
rozsah.>

Úvod do jednoduché vyhledávací syntaxe

Vložte vyhledávané fráze odd#lené mezerami. Ve výchozím nastavení vrátí funkce vyhledávání výsledky
obsahující všechna slova. Pokud chcete vyhledat pouze n#která z vložených slov, zvolte N#která slova.

6



Operace programu

Pokud si p#ejete provést komplexn#jší vyhledávání, zvolte Svobodný . P#íklady vyhledávání uvidíte po
kliknutí na plná sklatba.

You can use wildcards: '*' matches any number of characters, while '?' will match any single character.
The use of parenthesis allows you to group your search terms, e.g. '(Jesus OR spirit) AND God'.

Pro vyhledávání jiného než hlavního textu vložte ur#itou p#edponu následovanou'dvojte#kou ':' a
hledaným výrazem. Podívejte se na následující tabulku p#íklad#.

Available text types:

Table 3.1. Typy vyhledávání

P#edpona Význam P#íklad

heading: hledá hlavi#ky heading:Ježíš

footnote: hledá poznámky footnote:Mojžíš

strong: hledání Strongových #ísel strong:G535

morph: hledá morfologické kódy morph:N-GSM

Tip

M#žete kliknout na nainstalované dílo a vybrat O... pro nalzení nejvhodn#jších z výše uvedených
kritérií. Ne všechna díla mají zabudovány vlastnosti odpovídající tomuto typu vyhledávání.

BibleTime používá pro hledání vyhledávací engine Lucene, který má mnoho pokro#ilých vlastností. Více
si o n#m m#žete p#e#íst zde:  http://lucene.apache.org/java/docs/index.html [http://lucene.apache.org/
java/docs/index.html]

Výsledky hledání
Zde vidíte kolik p#ípad# hledaného #et#zce bylo nalezeno, set#íd#no podle d#l. Kliknutí na dílo pravým
tla#ítkem myši vám umožní kopírovat, uložit, nebo tisknout všechny verše které byli v daném díle
nalezeny. Kliknutím na jeden nebo více odkaz# ke kopírování, uložení nebo tisku. Kliknutí na ur#itý odkaz
otev#e verš v jeho kontextu v okn# náhledu.

Tip

P#etáhn#te odkaz a upus#te ho na symbol díla v knihovn# k otev#ení díla na tomto verši v novém
okn#.

Tip

P#etáhn#te odkaz a upus#te ho na otev#ené okno, které se p#esune na požadovanou pozici.

Tip

K vytvo#ení záložek vyberte odkazy a p#etáhn#te je do knihovny.

Analýza výsledk# hledání

Klikn#te na Analýza vahledávání pro zobrazení analýzy vyhledávání. Zobrazí jednoduchou grafickou
analýzu množství nalezených #et#zc# v každé knize Bible, analýzu m#žete uložit.
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Operace programu

Správa knih
Správa knih je nástroj pro správu knihovny. M#žete do vaší knihovny nainstalovat nová díla, nebo
aktualizovat #i odstranit ty existující. P#ístupná pod Nastavení → Správa knih v hlavním menu.

Install works
With this facility, you can connect to a repository of works (called "library"), and transfer one or more
works to your local Bookshelf. These libraries may be local (e.g. a SWORD CD), or remote (e.g.
Crosswire's online repository of SWORD modules, or another site offering SWORD modules). BibleTime
will automatically maintain a list of remote libraries and the works available from them.

To begin the installation process, select one or more libraries that you want to install works from. Then
click on the Next button. Then select one or more languages and click the Next button. You will see a list
of categories. Double-click on a category to see works for that category. Select one or more works and
then click on the Install Works. After the works are installed, click on the Finish.

Update works
If there are any works that can be updated, they will be shown. Select one or more work and click the
Update Works. After the works are updated, click on the Finish.

Remove works
This facility allows you to delete one or more of the works from your Bookshelf too free up disk space.
Simply choose the works` and click on the Remove works button.

Export a tisk
Na mnoha místech m#žete vyvolat kontextové menu kliknutím pravým tla#ítkem myši. V závislosti na
kontextu je možné Vybrat, Kopírovat (do schránky), Uložit nebo Tisknout. to funguje nap#. v aktivním
okn# když kliknete na b#žný text nebo na odkaz verše, nebo na stránce výsledk# hledání p#i kliknutí na
dílo nebo na jeden #i více odkaz# verš#. Je to velmi p#ímo#aré, prost# to vyzkoušejte.

Tisk z BibleTime spíše základní a je zamýšlen jako pom#cka. Pokud vytvá#íte dokument nebo prezentaci
obsahující text d#l z BibleTime, doporu#ujeme formátovat dokument za použití systémových nástroj# pro
tvorbu prezentací, nebo editaci textu, rad#ji než tisknout p#ímo z BibleTime.

8



Chapter 4. Nastavení BibleTime
V této sekci najdete úvod k nastavení BibleTime které najdete pod volbou Nastavení v hlavním menu.

Dialog Nastavení BibleTime
Uživatelské rozhraní programu BibleTime m#že být uzp#sobeno v mnoha sm#rech, v závislosti na vašich
pot#ebách. K dialogu nastavení m#žete p#istoupit výb#rem Nastavení Natavit BibleTime.

Display
M#žete uzp#sobit chování po spušt#ní. Vyberte z následujících možností:

• Zobrazovat uvítací obrazovku

Šablony zobrazení ur#ují zp#sob zobrazení textu (barvu, velikost atd.). P#ímo dostupných je více šablon.
Když jednu z nich zvolíte, objeví se náhled v pravém poli.

Desk
Mnoho vlastností poskytovaných backendem SWORD m#žete nyní v BibleTime nastavit. Tyto vlastnosti
jsou zdokumentovány v dialogu vpravo. Máte možnost vybrat výchozí díla, která mají být použita, když
není žádné dílo vybráno odkazem. Nap#íklad: výchozí Bible je použita k zobrazení obsahu "k#ížových"
biblických odkaz#. Když najedete nad odkaz, #asopis zobrazí náhled obsahu verš# odkazujících na toto
místo, ve výchozí Bibli kterou jste zvolili. S pomocí textových filtr# m#žete nastavit vzhled textu.

Languages
Zde m#žete zvolit jazyk, který bude použit pro jména biblických knih. Pokud je dostupný, nastavte tuto
možnost na váš jazyk, a budete se cítit doma.

V základním nastavení používá BibleTime výchozí systémové písmo. Pokud je to nezbytné, m#žete to
zm#nit. N#které jazyky vyžadují pro správné zobrazení speciální písma, tento dialog vám umožní nastavit
vlastní písmo pro každý jazyk.

Dialog nastavení - Písma

BibleTime umí používat všechna podporovaná písma. Pokud jsou díla o které se zajímáte zobrazena
správn#, není pot#eba zde nic m#nit.Pokud se dílo zobrazuje jen jako #et#zec otazník# (?????) nebo
prázdných #tverc#, pak víte, že standardní písmo neobsahuje znaky užité v tomto díle.

K náprav# vyberte jazyk tohoto díla z rozbalovacího menu. Zaškrtn#te použít vlastní písmo. Nyní vyberte
písmo. Nap#íklad, písmo podporující mnoho znak# je Code2000. Pokud žádné z nainstalovaných písem
neumí zobrazit dílo o které se zajímáte, zkuste nainstalovat lokaliza#ní balí#ek pro tento jazyk.

Instalace písem

Detailní popis instalace písem p#esahuje rozsah této p#íru#ky. Pro více informací m#žete použít  Unicode
HOWTO [http://www.linux.org/docs/ldp/howto/Unicode-HOWTO-2.html].

Fonts can be installed from a number of sources:
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Nastavení BibleTime

• Vaše *nixová distribuce.

• Lokaliza#ní balí#ky vaší distribuce.

• Existující instalace Microsoft Windows® na stejném po#íta#i.

• Kolekce písem, jako jsou dostupné od Adobe nebo Bitstream.

• Online kolekce písem

Písma Unicode podporují více znak# než ostatní písma, n#která z nich jsou dostupná zdarma. Žádné z
dostupných písem neobsahuje všechny znaky definované standardem Unicode, takže budete možná chtít
použít r#zná písma pro r#zné jazyky.

Table 4.1. Písma Unicode

Code2000 [http://code2000.net/CODE2000.ZIP] Možná nejlepší svobodné písmo Unicode, pokrývá
široký výb#r znak#.

SIL unicode fonts [http://scripts.sil.org/cms/scripts/
page.php?site_id=nrsi&cat_id=FontDownloads]

Výborná písma Unicode od " Summer Institute of
Linguistics".

FreeFont [http://www.nongnu.org/freefont/] Nová svobodná iniciativa písma Unicode.

Crosswire's font directory [ftp://ftp.crosswire.org/
pub/sword/iso/latest/FONTS/]

R#zná písma p#ístupná z ftp Crosswire Bible
Society.

Bitstream CyberBit [http://aol-4.vo.llnwd.net/pub/
communicator/extras/fonts/windows/]

Pokrývají v#tšinou celý výb#r Unicode, ale mohou
spomalit BibleTime v závislosti na jejich velikosti.

Clearlyu Obsaženo v mnoha distribucích. Obsahuje
Evropské, #ecké, Hebrejské, Thajské.

Caslon, Monospace, Cupola, Caliban [http://
fontforge.sourceforge.net/sfds/]

#áste#n# odpovídající, pro informace se podívejte
na odkazovanou stránku.

Dobré seznamy písem Unicode na internetu, jako jedno od Christopha Singera( Vícejazy#ná Unicode
TrueType Fonts na internetu [http://www.slovo.info/unifonts.htm]), nebo jedno od Alana Wooda
(  výb#r znak# Unicode a písma Unicode, která je podporují [http://www.alanwood.net/unicode/
fontsbyrange.html]).

Shortcuts
Horké klávesy jsou speciální klávesové p#íkazy, které m#žete použít namísto položek v menu, nebo ikon.
Mnoho p#íkaz# v BibleTime má definovány horké klávesy (kompletní seznam naleznete v sekci Horké
klávesy). V#tšin# p#íkaz# BibleTime zde m#že p#i#adit horké klávesy. To je velmi užite#né pro rychlý
p#ístup k funkcím, které nejvíce pot#ebujete.

In the preceding example, F2, Bible Study HowTo has a secondary shortcut defined, CTRL+2.
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Chapter 5. Odkazy
Odkazy Hlavního menu

V této sekci najdete detailní popis všech položek základního menu BibleTime. Jsou rozt#íd#né stejn#, jak
se objevují v BibleTime, v#etn# pod#ízených položek zaznamenaných pod hlavní položkou menu ke které
náleží. Horké klávesy m#žete vid#t u každé položky; kompletní seznam všech horkých kláves naleznete
v sekce horkých kláves.

File

File 

→

 Open work

Open work. This will give you a menu that will allow you to open
installed books.

File 

→

 Quit (Ctrl+Q)

Zav#e BibleTime. BibleTime se vás zeptá, jestli si p#ejete zapsat
neuložené zm#ny na disk.

View

View 

→

 Fullscreen mode
(F5)

P#epíná zobrazení p#es celou obrazovku. Aktivujte tuto možnost
pokud chcete maximalizovat okno BibleTime.

View 

→

 Show Bookshelf

Zapne zobrazení knihovny. Zvolte tuto možnost pro zapnutí, nebo
vypnutí zobrazení knihovny vlevo. To m#že být praktické pokud
pot#ebujete více #asu pro #asopis.

View 

→

 Show Bookmarks

Zapne zobrazení knihovny. Zvolte tuto možnost pro zapnutí, nebo
vypnutí zobrazení knihovny vlevo. To m#že být praktické pokud
pot#ebujete více místa pro #asopis.

View 

→

 Show Mag

Zapne zobrazení #asopisu. Zvolte tuto možnost pro zapnutí nebo
vypnutí zobrazení #asopisu na levé stran#.

View 

→

 Show parallel text
headers

Toggles viewing of additional works Toggle this setting to allow
you to view additional works in parallel to your current open books.

View → Toolbars → Show main
(F6)

Toggles Main Toolbar display. Toggle this setting to turn the main
toolbar on or off.

View → Toolbars → Show
navigation

Toggles Navigation in works. Toggle this setting to add or remove
the navigation combo box in works. This can be handy to view the
full toolbar in the open works

View → Toolbars → Show works Toggles Toolbars in works. Toggle this setting to add or remove
the works icons in the open works.
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Odkazy

View → Toolbars → Show tools Toggles tools in works. Toggle this setting to add or remove the
tools icons in the open works.

View → Toolbars → Show format Toggles format. Toggle this setting when editing HTML in Personal
Commentaries. It will add or remove the formatting toolbar.

View → Toolbars → Show
toolbars in text windows

Toggles toolbars in works. Toggle this setting to add or remove the
complete toolbar in open works.

Search

Search 

→

 Search in
standard bible (Ctrl+Alt+F)

Otevírá dialog vyhledávání pouze pro vyhledávání ve výchozí
Bibli. Do vyhledávacího dialogu mohou být p#ídána další díla.
Detailn#jší popis vyhledávání najdete v sekci Vyhledávání v dílech.

Search 

→

 Search in open
work(s) (Ctrl+O)

Otevírá dialog vyhledávání ve všech dílech. Do vyhledávacího
dialogu mohou být p#ídána, #i z n#j odebrána, další díla. Detailn#jší
popis vyhledávání naleznete v sekci Vyhledávání v dílech.

Window

Window 

→

 Close window
(Ctrl+W)

Closes active window.

Window 

→

 Close all (Ctrl
+Alt+W)

Zav#e všechna otev#ená okna.

Window 

→

 Cascade (Ctrl
+J)

Všechna otev#ená okna do kaskády.

Window 

→

 Tile (Ctrl+I)

Rozmístit všechna otev#ená okna jako dlaždice.

Window 

→

 Tile vertically
(Ctrl+G)

Automaticky dláždí všechna otev#ená okna vertikáln#.

Window 

→

 Tile
horizontally (Ctrl+H)

Automaticky dláždí všechna otev#ená okna horizontáln#..

Window → Arrangement mode Controls the basic window arrangement behaviour. In the opening
context menu, you can either specify that you want to take care of
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the window arrangement yourself (Manual mode), Tabbed, Auto-
tile vertically, Auto-tile horizontally, Auto-tile or Auto-cascade.
Just try them out!

Window → Save session Ukládá aktuální sezení.. Otev#e kontextové menu, kde m#žete
zvolit již uložené sezení, které bude p#epsáno vaším aktuálním.
Podívejte se na další položku jak uložit nové sezení.

Window → Save as new session
(Ctrl+Alt+S)

Ukládá aktuální sezení pod novým jménem. Zeptá se na jméno pro
uložení sezení.

Window → Load session Na#te existující sezení. Otev#e kontextové menu, kde m#žete
vybrat existující sezení a na#íst ho.

Window → Delete session Vymaže existující sezení. Otev#e kontextové menu, kde m#žete
vybrat existující sezení, které má být vymazáno.

Settings

Settings 

→

 Configure
BibleTime

Otev#e hlavní konfigura#ní dialog BibleTime. M#žete nastavit
všechny vlastnosti BibleTime, podle vašich pot#eb. Prosím
navštivte sekci Nastavení BibleTime pro více informací.

Settings 

→

 Bookshelf
Manager (F4)

Otev#e dialog kde m#žete zm#nit vaše nastavení SWORD a
spravovat svou knihovnu. Další inormace naleznete v sekci Správce
knihovny.

Help

Help 

→

 Handbook (F1)

Otev#e p#íru#ku BibleTime, kterou práv# #tete.

Help 

→

 Bible Study
HowTo (F2)

Otev#e pr#vodce jak studovat Bibli. P#áním týmu BibleTime je,
aby toto HowTo podnítilo #tená#e ke studiu posvátných text#, k
tomu dozv#d#t se co #íkají. Tato p#íru#ka byla zvolena proto, že
neobhajuje doktrínu žádné konkrétní denominace. O#ekáváme, že
budete #íst a studovat Písma, abyste jim rozum#li. Když za#nete s
postojem, že chcete mít semeno Pán# v srdci, On vás nezklame.

Help 

→

 Tip of the Day (F3)

Opens a helpful tip The Tip of the Day provides a useful tip that
will assist in the use of BibleTime.

Help → About Otev#e okno s informacemi o projektu BibleTime obsahuje
informace o verzi BibleTime, p#isp#vatelích projektu, verzi
SWORD, verzi Qt a licen#ní ujednání.

Odkazy
V této sekci najdete popis ikon p#i#azených k otev#eným díl#m.
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Posouvá vp#ed historií.

Posouvá zp#t historií.

Vyberte nainstalovanou bibli.

Vyberte další bible.

Vyhledávání ve vybraných dílech

Nastavení zobrazení

Vyberte nainstalované komentá#e.

Vyberte další komentá#e.

Synchronizovat zobrazený údaj s aktivním oknem Bible.

Vber knihu.

Vyberte nainstalovaný glosá# nebo modlitbu.

Vyberte další glosá# nebo modlitbu.

Seznam horkých kláves
Toto je seznam všech horkých kláves a s nimi souvisejícího popisu v p#íru#ce. Horké klávesy jsou
set#íd#ny (p#ibližn#) abecedn#. Pokud chcete p#esn# v#d#t která z horkých kláves odpovídá té které
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položce menu, m#žete se podívat p#ímo do nabídek BibleTime (vždy se zde zobrazují horké klávesy),
nebo si prohlédn#te P#ehled hlavního menu.

Horká klávesa Popis

Alt+Left Posune zp#t v historii aktivního okna.

Alt+Right Posune vp#ed v historii aktivního okna.

Ctrl+Alt+F Hledat → Hledat ve výchozí bibli otev#e
vyhledávací dialog pro vyhledávání ve výchozí
bibli.

Ctrl+Alt+G Okno → Mód rozvržení → Automaticky dlaždice
vertikáln# zapnout automatické skládání oken.

Ctrl+Alt+H Okno → Mód rozvržení → Automaticky dlaždice
horizontáln# zapne automatické skládání oken.

Ctrl+Alt+I Okno → Mód rozvržení → Automaticky dlaždice
vertikáln# ekvivalent k zapnout automatické
skládání oken.

Ctrl+Alt+J Okno → Mód rozvržení → Automaticky
kaskádovat zapne automatické skládání oken do
kaskády.

Ctrl+Alt+M Okno → Mód rozvržení → Ru#ní mód zapne
manuální skládání oken.

Ctrl+Alt+T Window → Arrangement mode → Tabbed
equivalent; organizes windows with tabs across the
top.

Ctrl+Alt+S Okno → Uložit jako novou relaci  uloží aktuální
náhled jako novou relaci.

Ctrl+Alt+W Okno → Zav#ít vše  zav#e všechna otev#ená okna.

Ctrl+A Vybrat vše. Vybere všechen text v aktivním okn#.

Ctrl+C Kopírovat. Zkopíruje vybraný text do schránky.

Ctrl+F Hledat. Vyhledává v textu aktivního okna

Ctrl+G Okno → Dlaždice vertikáln# .

Ctrl+H Okno → Dlaždice horizontáln# .

Ctrl+I Okno → Kaskádovat  ekvivalent oken.

Ctrl+J Okno → Kaskáda  obdoba oken.

Ctrl+L Zm#nit umíst#ní. Pro vybrané dílo zm#ní zam##ení
na nástrojovou lištu.

Ctrl+N Vyhledávat s díly tohoto okna.

Ctrl+O Hledat → Hledat v otev#ených dílech  otev#e dialog
pro vyhledávání ve všech otev#ených dílech.

Ctrl+Q Soubor → Ukon#it  ukon#í BibleTime.

Ctrl+W Zav#e aktuální okno.

F1 Nápov#da → P#íru#ka otev#e p#íru#ku.

F2 Help → BibleStudy HowTo equivalent; opens the
BibleStudy HowTo.
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Horká klávesa Popis

F3 Help → Tip of the Day Opens a helpful tip to use
BibleTime.

F4 Nastavení → Správa knih otev#e správce knih.

F8 Pohled → Zobrazit knihovnu zapne zobrazení
knihovny.

F9 Pohled → Zobrazit #asopis zapne zobrazení okna
#asopisu.

Shift+Down View → Auto scroll down

Shift+Up View → Auto scroll up

Space View → Auto scroll pause
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